天天看點

最大子列和問題

版權聲明:本文為部落客原創文章,未經部落客允許不得轉載。 https://blog.csdn.net/sinat_32502811/article/details/77850560

01-複雜度1 最大子列和問題(20 分)

給定K個整數組成的序列{ N

​1

​​ , N

​2

​​ , …, N

​K

​​ },“連續子列”被定義為{ N

​i

​i+1

​j

​​ },其中 1≤i≤j≤K。“最大子列和”則被定義為所有連續子列元素的和中最大者。例如給定序列{ -2, 11, -4, 13, -5, -2 },其連續子列{ 11, -4, 13 }有最大的和20。現要求你編寫程式,計算給定整數序列的最大子列和。

本題旨在測試各種不同的算法在各種資料情況下的表現。各組測試資料特點如下:

資料1:與樣例等價,測試基本正确性;

資料2:102個随機整數;

資料3:103個随機整數;

資料4:104個随機整數;

資料5:105個随機整數;

輸入格式:

輸入第1行給出正整數K (≤100000);第2行給出K個整數,其間以空格分隔。

輸出格式:

在一行中輸出最大子列和。如果序列中所有整數皆為負數,則輸出0。

輸入樣例:

6

-2 11 -4 13 -5 -2

輸出樣例:

20

#include <stdio.h>

int MaxSubseqSum1(int A[], int N);
int MaxSubseqSum2(int A[], int N);//分治法
int MaxSubseqSum3(int A[], int N);//動态規劃

int main() {
    int N;
    int A[100000];
    int Max= 0;
    scanf("%d", &N);
    for (int i = 0; i < N; i++) {
            scanf("%d", &A[i]);
    }
    Max = MaxSubseqSum3(A, N);
    if(Max < 0) Max = 0;
    printf("%d\n",Max);
    return 0;
}

int MaxSubseqSum1(int A[], int N) {
    int Sum, MaxSum;
    int i, j;
    MaxSum = 0;
    for (i = 0; i < N; i++) {
        Sum = 0;
        for (j = i; j < N; j++) {
            Sum += A[j];
            if (Sum > MaxSum) {
                MaxSum = Sum;
            }
        }
    }
    if (MaxSum < 0)
        MaxSum = 0;
    return MaxSum;
}

int Max3(int A, int B, int C) {
  return A > B ? A > C ? A : C : B > C ? B : C;
}
int DivideAndConquer(int List[], int left, int right) {
    int MaxLeftSum, MaxRightSum;
    int MaxLeftBorderSum, MaxRightBorderSum;
    int LeftBorderSum, RightBorderSum;
    int center, i;
    if (left == right) {
        if (List[left] > 0) return List[left];
        else return 0;
    }
    center = (left + right) / 2;
    MaxLeftSum = DivideAndConquer(List, left, center);
    MaxRightSum = DivideAndConquer(List, center + 1, right);
    MaxLeftBorderSum = 0;
    LeftBorderSum = 0;
    for (i = center; i >= left; i--) {
        LeftBorderSum += List[i];
        if (LeftBorderSum > MaxLeftBorderSum)
            MaxLeftBorderSum = LeftBorderSum;
    }
    MaxRightBorderSum = 0;
    RightBorderSum = 0;
    for (i = center + 1; i <= right; i++) {
        RightBorderSum += List[i];
        if (RightBorderSum > MaxRightBorderSum)
            MaxRightBorderSum = RightBorderSum;
    }
    return Max3(MaxLeftBorderSum + MaxRightBorderSum, MaxLeftSum, MaxRightSum);
}
int MaxSubseqSum2(int A[], int N) {
    return DivideAndConquer(A, 0, N - 1);
}
int MaxSubseqSum3(int A[], int N) {
    int ThisSum, MaxSum;
    int i;
    ThisSum = MaxSum = 0;
    for (i = 0; i < N; i++) {
        ThisSum += A[i];
        if (ThisSum > MaxSum)
            MaxSum = ThisSum;
        else if(ThisSum < 0)
        {
            ThisSum = 0;
        }
    }
    return MaxSum;
}           

主要是寫了三個算法。比較重要的是第二個分治法的了解和第三個動态規劃的了解。二者的時間複雜度分别為O(nlogn)和O(n)

01-複雜度2 Maximum Subsequence Sum(25 分)

Given a sequence of K integers { N

​1 , N2, …, NK}. A continuous subsequence is defined to be { N

​i​​ , Ni+1, …, N​j} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10

-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

#include <stdio.h>
#include <time.h>


int MaxSubseqSum3(int A[], int N);
int START;
int END;

int main() {
    int N;
    int A[10000];
    int j = 0;
    int Max,a,b;
    scanf("%d", &N);
    for (int i = 0; i < N; i++) {
        scanf("%d", &A[i]);
    }
    Max = MaxSubseqSum3(A, N);
    a = A[START];
    b = A[END];
    printf("%d %d %d\n", Max,a,b);
    return 0;
}
int MaxSubseqSum3(int A[], int N) {
    int ThisSum = 0;
    int MaxSum = -1;
    int i;
    int start = 0;int starttemp = 0;
    int end = N-1 ;int endtemp = 0;
    for (i = 0; i < N; i++) {
        ThisSum += A[i];

        if (ThisSum > MaxSum) {
            MaxSum = ThisSum;
            start = starttemp;
            end = i;
        }
        else if (ThisSum < 0){
            ThisSum = 0;
            starttemp = i + 1;
        }
    }
    if (MaxSum < 0) MaxSum = 0;
    START = start;
    END = end;
    return MaxSum;
}           

這裡主要用的是動态規劃的算法,我認為比較重要的一點就是一開始就對最大和MaxSum設定為-1,這樣在測試數列全為負數時比較好處理。

繼續閱讀