天天看點

hdu-5500 Reorder the Books

Reorder the Books

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1834 Accepted Submission(s): 949

Problem Description

dxy has a collection of a series of books called “The Stories of SDOI”,There are n(n≤19) books in this series.Every book has a number from 1 to n.

dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them.

One day Evensgn visited dxy’s home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about “Little E&Little Q”. While losing himself in the story,he disrupted the order of the books.

Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top.

Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book “The Stories of SDOI 9: The Story of Little E” as a gift.

Input

There are several testcases.

There is an positive integer T(T≤30) in the first line standing for the number of testcases.

For each testcase, there is an positive integer n in the first line standing for the number of books in this series.

Followed n positive integers separated by space standing for the order of the disordered books,the ith integer stands for the ith book’s number(from top to bottom).

Hint:

For the first testcase:Moving in the order of book3,book2,book1 ,(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4),and this is the best way to reorder the books.

For the second testcase:It’s already ordered so there is no operation needed.

Output

For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.

Sample Input

2

4

4 1 2 3

5

1 2 3 4 5

Sample Output

3

Source

BestCoder Round #59 (div.1)

**

給定n個數,每次選一個數放到最前面,最少選多少次可以使得這個數組從小到大排序。

1 3 2 4

1 2 3 4

先排最大的,再排次大的,以此類推。

從後往前選,如果目前最後一個數字是目前最大的,說明已經比對不用選該數字,繼續往前選 同時由于這個數字已經比對,目前最大數字也往前遞推變次大;如果目前最後一個不是最大的, 則選取該數字到最前面,目前最大數字不變,繼續往前選

**。

/*
  給定n個數,每次選一個數放到最前面,最少選多少次可以使得這個數組從小到大排序。
  1 3 2 4
  1 2 3 4
  先排最大的,再排次大的,以此類推。
  
  從後往前選,如果目前最後一個數字是目前最大的,說明已經比對不用選該數字,繼續往前選
  同時由于這個數字已經比對,目前最大數字也往前遞推變次大;如果目前最後一個不是最大的,
  則選取該數字到最前面,目前最大數字不變,繼續往前選。
  
*/
#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+10;
int T,n,a[maxn],b[maxn];
int main()
{
    cin >> T;
    while(T--)
    {
        cin >> n;
        for(int i=1;i<=n;i++)
        {
            cin >> a[i];
            b[i]=a[i];
        }
        sort(b+1,b+1+n);
        int cur=n,ans=0;
        for(int i=n;i>=1;i--)
        {
            if(a[i]==b[cur])
                cur--;
            else
                ans++;
        }
        cout << ans << endl;

    }


    return 0;
}

           

題意:

你個數自,操作:每一個數字隻能移到第一個位置,問最少操作的次數

分析:

這題以前做過:https://blog.csdn.net/sdz20172133/article/details/86581609,但是當時的想法隻能對于1~n的全排列,這個題就gg了,本來以為離散化就ok了,2 3 2 3樣例卡死,最後,隊友想了一個方法才過的;

正解:

首先我們發現越大的數越不要動,目前最大的數可以不動,把他們中間的數必須移動,而把這些越大的數到前面隻會浪費次數。

我們開一個b數組對數組進行排序,對于最大的數我們是可以不動,緊接次大。。。。。

繼續閱讀

繼續閱讀